Repository navigation
fix(deps): update dependency opentelemetry-api to v1.45.1 [security] #14769
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
base: main
Are you sure you want to change the base?
Changes from all commits
File filter
Filter by extension
Conversations
Jump to
Diff view
Diff view
There are no files selected for viewing
| Original file line number | Diff line number | Diff line change | ||||||||||||
|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
|
|
@@ -6,7 +6,7 @@ readme = "README.md" | |||||||||||||
| requires-python = ">=3.10" | ||||||||||||||
| dependencies = [ | ||||||||||||||
| "fastmcp==3.4.3", | ||||||||||||||
| "opentelemetry-api==1.40.0", | ||||||||||||||
| "opentelemetry-api==1.45.1", | ||||||||||||||
| "opentelemetry-sdk==1.40.0", | ||||||||||||||
| "opentelemetry-exporter-otlp-proto-grpc==1.40.0", | ||||||||||||||
|
Comment on lines
+9
to
11
Contributor
There was a problem hiding this comment. Choose a reason for hiding this commentThe reason will be displayed to describe this comment to others. Learn more. When upgrading
Suggested change
|
||||||||||||||
| "google-auth==2.62.0", | ||||||||||||||
|
|
||||||||||||||
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
When upgrading
opentelemetry-apito1.45.1, it is highly recommended to also upgradeopentelemetry-sdkandopentelemetry-exporter-otlp-proto-grpcto the same version (1.45.1). Mixing different minor/patch versions of OpenTelemetry components can lead to runtime compatibility issues and unexpected behavior.